$re = '/rating-inbtn[^>]+>\s*([^\s<]+)\s*<\//m';
$str = '<span class="vote-actions">
<a class="btn btn-default vote-action-good">
<span class="icon thumb-up black black-hover"> </span>
<span class="rating-inbtn">215</span>
</a>
<a class="btn btn-default vote-action-bad">
<span class="icon thumb-down grey black-hover"> </span>
<span class="rating-inbtn">82</span>
<span class="rating-inbtn"> 74 </span>
<span class="rating-inbtn hide-if-zero-113"> 99 </span>
</a>
</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);