package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)rating-inbtn[^>]+>\s*([^\s<]+)\s*<\/`)
var str = `<span class="vote-actions">
<a class="btn btn-default vote-action-good">
<span class="icon thumb-up black black-hover"> </span>
<span class="rating-inbtn">215</span>
</a>
<a class="btn btn-default vote-action-bad">
<span class="icon thumb-down grey black-hover"> </span>
<span class="rating-inbtn">82</span>
<span class="rating-inbtn"> 74 </span>
<span class="rating-inbtn hide-if-zero-113"> 99 </span>
</a>
</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}