package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http(s)?://i\.redd\.it/\w+\.(png|gif|jpg|jpeg)$`)
var str = `https://i.redd.it/somestr1ng.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}