$re = '/^http(s)?://i\.redd\.it/\w+\.(png|gif|jpg|jpeg)$/m';
$str = 'https://i.redd.it/somestr1ng.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);