#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]+$|^[0-9]+,[0-9]{1,2}$"
Local $sString = "5" & @CRLF & _
"5,5" & @CRLF & _
"5,55" & @CRLF & _
"" & @CRLF & _
"5," & @CRLF & _
"5,555" & @CRLF & _
"5,5555" & @CRLF & _
"a" & @CRLF & _
"5a" & @CRLF & _
"a5" & @CRLF & _
"a,5" & @CRLF & _
"5,a" & @CRLF & _
"a5,5" & @CRLF & _
"5a,5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")