re = /^[0-9]+$|^[0-9]+,[0-9]{1,2}$/m
str = '5
5,5
5,55
5,
5,555
5,5555
a
5a
a5
a,5
5,a
a5,5
5a,5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end