import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+$|^[0-9]+,[0-9]{1,2}$";
final String string = "5\n"
+ "5,5\n"
+ "5,55\n\n"
+ "5,\n"
+ "5,555\n"
+ "5,5555\n"
+ "a\n"
+ "5a\n"
+ "a5\n"
+ "a,5\n"
+ "5,a\n"
+ "a5,5\n"
+ "5a,5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}