package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+$|^[0-9]+,[0-9]{1,2}$`)
var str = `5
5,5
5,55
5,
5,555
5,5555
a
5a
a5
a,5
5,a
a5,5
5a,5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}