#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x) # invoke extended (aka free-spacing) mode" & @CRLF & _
"^ # match beginning of the string" & @CRLF & _
"[^"\n]* # match zero or more chars other than line terminators and double-quotes" & @CRLF & _
"" # match a double-quote" & @CRLF & _
"[^"\n]* # match zero or more chars other than line terminators and double-quotes" & @CRLF & _
"[^ "\n] # match a character other than a space, double-quote or newline" & @CRLF & _
"" # match a double-quote" & @CRLF & _
"\n # match a newline" & @CRLF & _
"\ * # match zero or more spaces" & @CRLF & _
"" # match double-quote" & @CRLF & _
"[^ "\n] # match a character other than a space, double-quote or newline" & @CRLF & _
"[^"\n]* # match zero or more chars other than line terminators and double-quotes" & @CRLF & _
"" # match a double-quote" & @CRLF & _
"\n? # optionally match a newline" & @CRLF & _
"$ # match end of string"
Local $sString = "abc def "ghi jkl\n"" & @CRLF & _
" "mno pqr""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")