const regex = /(?x) # invoke extended (aka free-spacing) mode
^ # match beginning of the string
[^"\n]* # match zero or more chars other than line terminators and double-quotes
" # match a double-quote
[^"\n]* # match zero or more chars other than line terminators and double-quotes
[^ "\n] # match a character other than a space, double-quote or newline
" # match a double-quote
\n # match a newline
\ * # match zero or more spaces
" # match double-quote
[^ "\n] # match a character other than a space, double-quote or newline
[^"\n]* # match zero or more chars other than line terminators and double-quotes
" # match a double-quote
\n? # optionally match a newline
$ # match end of string/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x) # invoke extended (aka free-spacing) mode
^ # match beginning of the string
[^"\\n]* # match zero or more chars other than line terminators and double-quotes
" # match a double-quote
[^"\\n]* # match zero or more chars other than line terminators and double-quotes
[^ "\\n] # match a character other than a space, double-quote or newline
" # match a double-quote
\\n # match a newline
\\ * # match zero or more spaces
" # match double-quote
[^ "\\n] # match a character other than a space, double-quote or newline
[^"\\n]* # match zero or more chars other than line terminators and double-quotes
" # match a double-quote
\\n? # optionally match a newline
$ # match end of string', 'gm')
const str = `abc def "ghi jkl\\n"
"mno pqr"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}