import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x) # invoke extended (aka free-spacing) mode\n"
+ "^ # match beginning of the string\n"
+ "[^\"\\n]* # match zero or more chars other than line terminators and double-quotes\n"
+ "\" # match a double-quote\n"
+ "[^\"\\n]* # match zero or more chars other than line terminators and double-quotes\n"
+ "[^ \"\\n] # match a character other than a space, double-quote or newline\n"
+ "\" # match a double-quote\n"
+ "\\n # match a newline\n"
+ "\\ * # match zero or more spaces\n"
+ "\" # match double-quote\n"
+ "[^ \"\\n] # match a character other than a space, double-quote or newline\n"
+ "[^\"\\n]* # match zero or more chars other than line terminators and double-quotes\n"
+ "\" # match a double-quote\n"
+ "\\n? # optionally match a newline\n"
+ "$ # match end of string";
final String string = "abc def \"ghi jkl\\n\"\n"
+ " \"mno pqr\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}