re = /(?x) # invoke extended (aka free-spacing) mode
^ # match beginning of the string
[^"\n]* # match zero or more chars other than line terminators and double-quotes
" # match a double-quote
[^"\n]* # match zero or more chars other than line terminators and double-quotes
[^ "\n] # match a character other than a space, double-quote or newline
" # match a double-quote
\n # match a newline
\ * # match zero or more spaces
" # match double-quote
[^ "\n] # match a character other than a space, double-quote or newline
[^"\n]* # match zero or more chars other than line terminators and double-quotes
" # match a double-quote
\n? # optionally match a newline
$ # match end of string/m
str = 'abc def "ghi jkl\\n"
"mno pqr"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end