use strict;
my $str = '(12)98272-8620
55 12 98272-8620';
my $regex = qr/^\(\d+\)/mp;
my $subst = '55 12 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";