#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\d+\.\d+\s+Section[\w\W]+?(?=\R*(?:\d+\.\d+|$))"
Local $sString = "1.1 Section " & @CRLF & _
"" & @CRLF & _
"dsfdsf" & @CRLF & _
"g" & @CRLF & _
"fdgdf" & @CRLF & _
"g" & @CRLF & _
"dfgfdg" & @CRLF & _
"" & @CRLF & _
"1.2 Section" & @CRLF & _
"" & @CRLF & _
"This is the " & @CRLF & _
"first section" & @CRLF & _
"" & @CRLF & _
"1.3 Section" & @CRLF & _
"dfgdfgfd" & @CRLF & _
"g" & @CRLF & _
"dfgdfg" & @CRLF & _
"" & @CRLF & _
"1.4 Section" & @CRLF & _
"dfgfdgfd" & @CRLF & _
"g" & @CRLF & _
"fdg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")