use strict;
my $str = '1.1 Section
dsfdsf
g
fdgdf
g
dfgfdg
1.2 Section
This is the
first section
1.3 Section
dfgdfgfd
g
dfgdfg
1.4 Section
dfgfdgfd
g
fdg';
my $regex = qr/\d+\.\d+\s+Section[\w\W]+?(?=\R*(?:\d+\.\d+|$))/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}