import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\.\\d+\\s+Section[\\w\\W]+?(?=\\R*(?:\\d+\\.\\d+|$))";
final String string = "1.1 Section \n\n"
+ "dsfdsf\n"
+ "g\n"
+ "fdgdf\n"
+ "g\n"
+ "dfgfdg\n\n"
+ "1.2 Section\n\n"
+ "This is the \n"
+ "first section\n\n"
+ "1.3 Section\n"
+ "dfgdfgfd\n"
+ "g\n"
+ "dfgdfg\n\n"
+ "1.4 Section\n"
+ "dfgfdgfd\n"
+ "g\n"
+ "fdg";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}