$re = '/\d+\.\d+\s+Section[\w\W]+?(?=\R*(?:\d+\.\d+|$))/i';
$str = '1.1 Section
dsfdsf
g
fdgdf
g
dfgfdg
1.2 Section
This is the
first section
1.3 Section
dfgdfgfd
g
dfgdfg
1.4 Section
dfgfdgfd
g
fdg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);