#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*blacklisted[": ]+false[,\r\n\s"]+userId[": ]+example@example\.com"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "networkChangeEvents" : true," & @CRLF & _
" "url" : "<removed>"," & @CRLF & _
" "userId" : "<removed>"," & @CRLF & _
" "seqEvents" : true," & @CRLF & _
" "testEvents" : true," & @CRLF & _
" "blacklisted" : true," & @CRLF & _
" "webAlertEvents" : true," & @CRLF & _
" "sqaEvents" : true" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "url" : "<removed>"," & @CRLF & _
" "networkChangeEvents" : false," & @CRLF & _
" "userId" : "<removed>"," & @CRLF & _
" "seqEvents" : true," & @CRLF & _
" "testEvents" : false," & @CRLF & _
" "blacklisted" : false," & @CRLF & _
" "webAlertEvents" : false," & @CRLF & _
" "sqaEvents" : true" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "networkChangeEvents" : false," & @CRLF & _
" "url" : "<removed>"," & @CRLF & _
" "seqEvents" : false," & @CRLF & _
" "blacklisted" : false," & @CRLF & _
" "userId" : "example@example.com"" & @CRLF & _
" "testEvents" : false," & @CRLF & _
" "webAlertEvents" : false," & @CRLF & _
" "sqaEvents" : true" & @CRLF & _
" }," & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")