import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*blacklisted[\": ]+false[,\\r\\n\\s\"]+userId[\": ]+example@example\\.com";
final String string = "[\n"
+ " {\n"
+ " \"networkChangeEvents\" : true,\n"
+ " \"url\" : \"<removed>\",\n"
+ " \"userId\" : \"<removed>\",\n"
+ " \"seqEvents\" : true,\n"
+ " \"testEvents\" : true,\n"
+ " \"blacklisted\" : true,\n"
+ " \"webAlertEvents\" : true,\n"
+ " \"sqaEvents\" : true\n"
+ " },\n"
+ " {\n"
+ " \"url\" : \"<removed>\",\n"
+ " \"networkChangeEvents\" : false,\n"
+ " \"userId\" : \"<removed>\",\n"
+ " \"seqEvents\" : true,\n"
+ " \"testEvents\" : false,\n"
+ " \"blacklisted\" : false,\n"
+ " \"webAlertEvents\" : false,\n"
+ " \"sqaEvents\" : true\n"
+ " },\n"
+ " {\n"
+ " \"networkChangeEvents\" : false,\n"
+ " \"url\" : \"<removed>\",\n"
+ " \"seqEvents\" : false,\n"
+ " \"blacklisted\" : false,\n"
+ " \"userId\" : \"example@example.com\"\n"
+ " \"testEvents\" : false,\n"
+ " \"webAlertEvents\" : false,\n"
+ " \"sqaEvents\" : true\n"
+ " },\n"
+ "]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}