re = /.*blacklisted[": ]+false[,\r\n\s"]+userId[": ]+example@example\.com/m
str = '[
{
"networkChangeEvents" : true,
"url" : "<removed>",
"userId" : "<removed>",
"seqEvents" : true,
"testEvents" : true,
"blacklisted" : true,
"webAlertEvents" : true,
"sqaEvents" : true
},
{
"url" : "<removed>",
"networkChangeEvents" : false,
"userId" : "<removed>",
"seqEvents" : true,
"testEvents" : false,
"blacklisted" : false,
"webAlertEvents" : false,
"sqaEvents" : true
},
{
"networkChangeEvents" : false,
"url" : "<removed>",
"seqEvents" : false,
"blacklisted" : false,
"userId" : "example@example.com"
"testEvents" : false,
"webAlertEvents" : false,
"sqaEvents" : true
},
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end