use strict;
my $str = '[
{
"networkChangeEvents" : true,
"url" : "<removed>",
"userId" : "<removed>",
"seqEvents" : true,
"testEvents" : true,
"blacklisted" : true,
"webAlertEvents" : true,
"sqaEvents" : true
},
{
"url" : "<removed>",
"networkChangeEvents" : false,
"userId" : "<removed>",
"seqEvents" : true,
"testEvents" : false,
"blacklisted" : false,
"webAlertEvents" : false,
"sqaEvents" : true
},
{
"networkChangeEvents" : false,
"url" : "<removed>",
"seqEvents" : false,
"blacklisted" : false,
"userId" : "example@example.com"
"testEvents" : false,
"webAlertEvents" : false,
"sqaEvents" : true
},
]';
my $regex = qr/.*blacklisted[": ]+false[,\r\n\s"]+userId[": ]+example@example\.com/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}