using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<cookie>(?<name>[^=]+)=(?<value>[^;]+);)";
string input = @"name1=value1;name2=value2; name3=value3;
name4=value4;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}