// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<cookie>(?<name>[^=]+)=(?<value>[^;]+);)").unwrap();
let string = "name1=value1;name2=value2; name3=value3;
name4=value4;
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}