package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<cookie>(?<name>[^=]+)=(?<value>[^;]+);)`)
var str = `name1=value1;name2=value2; name3=value3;
name4=value4;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}