re = /(?<cookie>(?<name>[^=]+)=(?<value>[^;]+);)/m
str = 'name1=value1;name2=value2; name3=value3;
name4=value4;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end