using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""bookIds""\s*:\s*\[([^\]]+?)]";
string input = @"<html>
<head>
</head>
<body>
<script type=""text/javascript"">
... more code ...
},
""bookIds"" : [
""abc123"",
""qwe456"",
""asd789""
],
... more code, and in another json:
},
""bookIds"" : [
""foo111"",
""bar222"",
""baz333""
],
... more code ...
</script>
</body>
</html>";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}