# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"bookIds\"\s*:\s*\[([^\]]+?)]"
test_str = ("<html>\n"
" <head>\n"
" </head>\n"
" <body>\n"
" <script type=\"text/javascript\">\n"
" ... more code ...\n"
" },\n"
" \"bookIds\" : [\n"
" \"abc123\",\n"
" \"qwe456\",\n"
" \"asd789\"\n"
" ],\n"
" ... more code, and in another json:\n"
" },\n"
" \"bookIds\" : [\n"
" \"foo111\",\n"
" \"bar222\",\n"
" \"baz333\"\n"
" ],\n"
" ... more code ...\n"
" </script>\n"
" </body>\n"
"</html>")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.