import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"bookIds\"\\s*:\\s*\\[([^\\]]+?)]";
final String string = "<html>\n"
+ " <head>\n"
+ " </head>\n"
+ " <body>\n"
+ " <script type=\"text/javascript\">\n"
+ " ... more code ...\n"
+ " },\n"
+ " \"bookIds\" : [\n"
+ " \"abc123\",\n"
+ " \"qwe456\",\n"
+ " \"asd789\"\n"
+ " ],\n"
+ " ... more code, and in another json:\n"
+ " },\n"
+ " \"bookIds\" : [\n"
+ " \"foo111\",\n"
+ " \"bar222\",\n"
+ " \"baz333\"\n"
+ " ],\n"
+ " ... more code ...\n"
+ " </script>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}