// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"bookIds"\s*:\s*\[([^\]]+?)]"#).unwrap();
let string = "<html>
<head>
</head>
<body>
<script type=\"text/javascript\">
... more code ...
},
\"bookIds\" : [
\"abc123\",
\"qwe456\",
\"asd789\"
],
... more code, and in another json:
},
\"bookIds\" : [
\"foo111\",
\"bar222\",
\"baz333\"
],
... more code ...
</script>
</body>
</html>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}