using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*([,\._\- ]).*\1)(?!.*[',\._\- ]{2})(?!.*(['])(?:.*\2){2})[',\._\- \p{L}]+$";
string input = @"O'Leary-Smith
O'Leary-Sm-ith
O'Lea'ry-Smith
John
O'Lea.ry-Smith
O''Leary
O Leary Smith
O Leary-Smith
O'Leary-D'angelo
O'Leary-D'angelo'dfff
O'Leary-Dangelo
O''Leary-Dangelo
Test-.ffoof
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}