import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*([,\\._\\- ]).*\\1)(?!.*[',\\._\\- ]{2})(?!.*(['])(?:.*\\2){2})[',\\._\\- \\p{L}]+$";
final String string = "O'Leary-Smith\n"
+ "O'Leary-Sm-ith\n"
+ "O'Lea'ry-Smith\n"
+ "John\n"
+ "O'Lea.ry-Smith\n"
+ "O''Leary\n"
+ "O Leary Smith\n"
+ "O Leary-Smith\n"
+ "O'Leary-D'angelo\n"
+ "O'Leary-D'angelo'dfff\n"
+ "O'Leary-Dangelo\n"
+ "O''Leary-Dangelo\n"
+ "Test-.ffoof\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}