re = /^(?!.*([,\._\- ]).*\1)(?!.*[',\._\- ]{2})(?!.*(['])(?:.*\2){2})[',\._\- \p{L}]+$/m
str = 'O\'Leary-Smith
O\'Leary-Sm-ith
O\'Lea\'ry-Smith
John
O\'Lea.ry-Smith
O\'\'Leary
O Leary Smith
O Leary-Smith
O\'Leary-D\'angelo
O\'Leary-D\'angelo\'dfff
O\'Leary-Dangelo
O\'\'Leary-Dangelo
Test-.ffoof
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end