import re
regex = re.compile(r"^(?!.*([,\._\- ]).*\1)(?!.*[',\._\- ]{2})(?!.*(['])(?:.*\2){2})[',\._\- \p{L}]+$", flags=re.MULTILINE)
test_str = ("O'Leary-Smith\n"
"O'Leary-Sm-ith\n"
"O'Lea'ry-Smith\n"
"John\n"
"O'Lea.ry-Smith\n"
"O''Leary\n"
"O Leary Smith\n"
"O Leary-Smith\n"
"O'Leary-D'angelo\n"
"O'Leary-D'angelo'dfff\n"
"O'Leary-Dangelo\n"
"O''Leary-Dangelo\n"
"Test-.ffoof\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")