import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Fp|Dev)_.*_[0-9]{1,3}$";
final String string = "Dev_xxxxx-1111\n"
+ "Dev_xxxxx-111\n"
+ "1.3.0.0-amd64\n"
+ "Dev_08346f824a146dafbdca4b63eb3ce0b1549c6346_165\n"
+ "Dev_0ab8997f5d45ed6b7515b5148d492c98109bf94a_16\n"
+ "Dev_f64db4c58d6a0eddeec3c12c74d5fbba1849886d_16620\n"
+ "1.3.0.0-amd64\n"
+ "Dev_04938095cc4bcefb1f85d7b306c1c49d335e80ce_167075";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}