# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(Fp|Dev)_.*_[0-9]{1,3}$"
test_str = ("Dev_xxxxx-1111\n"
"Dev_xxxxx-111\n"
"1.3.0.0-amd64\n"
"Dev_08346f824a146dafbdca4b63eb3ce0b1549c6346_165\n"
"Dev_0ab8997f5d45ed6b7515b5148d492c98109bf94a_16\n"
"Dev_f64db4c58d6a0eddeec3c12c74d5fbba1849886d_16620\n"
"1.3.0.0-amd64\n"
"Dev_04938095cc4bcefb1f85d7b306c1c49d335e80ce_167075")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.