// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(Fp|Dev)_.*_[0-9]{1,3}$").unwrap();
let string = "Dev_xxxxx-1111
Dev_xxxxx-111
1.3.0.0-amd64
Dev_08346f824a146dafbdca4b63eb3ce0b1549c6346_165
Dev_0ab8997f5d45ed6b7515b5148d492c98109bf94a_16
Dev_f64db4c58d6a0eddeec3c12c74d5fbba1849886d_16620
1.3.0.0-amd64
Dev_04938095cc4bcefb1f85d7b306c1c49d335e80ce_167075";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}