const regex = /^(Fp|Dev)_.*_[0-9]{1,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Fp|Dev)_.*_[0-9]{1,3}$', 'gm')
const str = `Dev_xxxxx-1111
Dev_xxxxx-111
1.3.0.0-amd64
Dev_08346f824a146dafbdca4b63eb3ce0b1549c6346_165
Dev_0ab8997f5d45ed6b7515b5148d492c98109bf94a_16
Dev_f64db4c58d6a0eddeec3c12c74d5fbba1849886d_16620
1.3.0.0-amd64
Dev_04938095cc4bcefb1f85d7b306c1c49d335e80ce_167075`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}