#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\s+)([A-Z][a-z']+)(\s+)?"
Local $sString = "My friend John met Beatrice and Lucio" & @CRLF & _
"My friend John met Beatrice and Lucio" & @CRLF & _
"My friend Alice O'Neal met Beatrice and Lucio"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")