package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s+)([A-Z][a-z']+)(\s+)?`)
var str = `My friend John met Beatrice and Lucio
My friend John met Beatrice and Lucio
My friend Alice O'Neal met Beatrice and Lucio`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}