using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s+)([A-Z][a-z']+)(\s+)?";
string input = @"My friend John met Beatrice and Lucio
My friend John met Beatrice and Lucio
My friend Alice O'Neal met Beatrice and Lucio";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}