$re = '/(\s+)([A-Z][a-z\']+)(\s+)?/m';
$str = 'My friend John met Beatrice and Lucio
My friend John met Beatrice and Lucio
My friend Alice O\'Neal met Beatrice and Lucio';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);