#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:\r?\n){2,}"
Local $sString = "Paragraph 1: some paragraph text" & @CRLF & _
"some paragraph text some paragraph text" & @CRLF & _
"some paragraph text some paragraph text" & @CRLF & _
"" & @CRLF & _
"Paragraph 2: some paragraph text" & @CRLF & _
"some paragraph text some paragraph text" & @CRLF & _
"some paragraph text some paragraph text" & @CRLF & _
"" & @CRLF & _
"Paragraph 3: some paragraph text" & @CRLF & _
"some paragraph text some paragraph text" & @CRLF & _
"some paragraph text some paragraph text" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")