import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\r?\\n){2,}";
final String string = "Paragraph 1: some paragraph text\n"
+ "some paragraph text some paragraph text\n"
+ "some paragraph text some paragraph text\n\n"
+ "Paragraph 2: some paragraph text\n"
+ "some paragraph text some paragraph text\n"
+ "some paragraph text some paragraph text\n\n"
+ "Paragraph 3: some paragraph text\n"
+ "some paragraph text some paragraph text\n"
+ "some paragraph text some paragraph text\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}