re = /(?:\r?\n){2,}/i
str = 'Paragraph 1: some paragraph text
some paragraph text some paragraph text
some paragraph text some paragraph text
Paragraph 2: some paragraph text
some paragraph text some paragraph text
some paragraph text some paragraph text
Paragraph 3: some paragraph text
some paragraph text some paragraph text
some paragraph text some paragraph text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end