using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\r?\n){2,}";
string input = @"Paragraph 1: some paragraph text
some paragraph text some paragraph text
some paragraph text some paragraph text
Paragraph 2: some paragraph text
some paragraph text some paragraph text
some paragraph text some paragraph text
Paragraph 3: some paragraph text
some paragraph text some paragraph text
some paragraph text some paragraph text
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}