using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(@\w+\s)+";
string substitution = @"";
string input = @"@AlexWassabi @laurDIY now i type my text and i mention @mention and another @ohk";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}