// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(@\w+\s)+").unwrap();
let string = "@AlexWassabi @laurDIY now i type my text and i mention @mention and another @ohk";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}