$re = '/^(@\w+\s)+/';
$str = '@AlexWassabi @laurDIY now i type my text and i mention @mention and another @ohk';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;