package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)^(TECHNICAL|SUPPORT|ADMINISTRATIVE|BILLING|OTHER)$`)
var str = `TECHNICAL
SUPPORT
ADMINISTRATIVE
BILLING
OTHER
technical
tecHNICAL
AdMiNiStRaTiVe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}