$re = '/(?i)^(TECHNICAL|SUPPORT|ADMINISTRATIVE|BILLING|OTHER)$/m';
$str = 'TECHNICAL
SUPPORT
ADMINISTRATIVE
BILLING
OTHER
technical
tecHNICAL
AdMiNiStRaTiVe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);